Copy/Paste fails to create visual structure element // FF Dev

Using Latest SwissKnife and latest Oxygen, when Copy/Pasting div inside same template, element is not displayed inside structure panel but is is created in template (see attached image). Using FF Dev browser. After saving the template, structure is still not OK, but after reloading builder, structure is updated to correct state. Most likely related to […]

Swiss Knife

Back to admin / Preview page have same icons in builder when editing template

Using latest SKN and latest Oxygen, icons for “Back to admin” and “Preview page” are the same – default WP logo. Source taken from /wp-content/plugins/swiss-knife/features/css/theme.css oxygen-topbar .oxygen-back-to-wp-menu .oxygen-toolbar-button-dropdown a { width: 45px; text-indent: -999px; background-color: var(–oxy__bg-2); background: url(“../img/topbar/back-to-wp.svg”); background-color: rgba(0, 0, 0, 0); background-position-x: 0%; background-position-y: 0%; background-repeat: repeat; background-size: auto; background-repeat: no-repeat; background-position: center; […]

Swiss Knife

Laggy Oxygen–>Settings–>Global Styles when “Display breakpoints size on hover” is enabled

Using SwissKnife 2.0.2 and O2 3.9RC02 there is a significant lag noticed when accessing Settings inside builder when Display breakpoints size on hover is enabled (tested with various different setting for SwissKnife and i can almost certainly confirm that this specific feature is the culprit).  

Swiss Knife

SwissKnife 2.0.2 builder load

loading spinner is not centered on screen loading spinner is a bit too much design vise 😉 when builder loads, there is a approximately 1second window when builder is visible, after that, loading spinner reappears and about 3 seconds later, builder actually loads for editing SIGNIFICATN DIFFERENCE in builder load speed (Same template, emtpy header, […]

Swiss Knife